Universal FTP Interface System Guide

Universal FTP Interface System
Systems File Exchange

User Guide

UFTP/SFE Version 4.2
July 1, 2003

Systems Development and Automation Tools

For the latest information about Surround Technologies' products, visit: www.surroundtech.com

Copyright © 1998-2003 SURROUND TECHNOLOGIES, LLC.
Notice: This guide and the Software described by this guide are protected by copyright. You may not copy, modify, translate, or reproduce this guide or any part of this guide in any form without prior written permission from Surround Technologies, LLC.


End User License Agreement

IMPORTANT - PLEASE READ CAREFULLY: This End User License Agreement (this
"Agreement") is a legal agreement between you (either an individual or a single
entity) and Surround Technologies, LLC (Surround) for the Surround products
identified above, which includes computer software and associated media, printed
materials and electronic or "on-line" documentation (Software). By installing,
copying, or otherwise using the Software, you agree to be bound by the terms of
this Agreement. If you do not accept the terms of this Agreement, promptly
return the unused Software to the place in which you obtained it for a full
refund.

1.  GRANT OF LICENSE. Surround Technologies, LLC, grants you a nonexclusive
    license to use the Software, subject to the following:

     * Except as stated below, you may install the Software on only one computer. If
       the Software can be used from any computer other than the computer on which it
       is installed (whether because the computer on which it is installed is part of a
       network or for any other reason), you must license a copy of the Software for
       each computer from which the Software may be used. For example, if there are ten
       computers that have access to the Software on your network, then you must
       license ten copies of the Software solely for use on that network.

     * If you are the primary user of more than one computer (such as an office
       computer and a home computer), you may install the Software on each of them so
       long as the Software is never used on more than one of the computers at the same
       time. If you want to allow the Software to be used on more than one of the
       computers at the same time, then you must license a copy of the Software for
       each computer.

     * If you remotely install or otherwise install the Software on another user's
       computer for file transfers or other remote operations, you must delete the
       Software from the other computer immediately after you complete your transfer or
       remote operation.

     * You may make a reasonable number of back-up copies of the Software. The back-
       up copies may be used only to replace an unusable copy of the Software. You must
       destroy any copies of the Software that are replaced by a back-up copy. Back-up
       copies must include all proprietary rights notices appearing on the original and
       must remain in your possession or control.

     * Except as specifically permitted in this Agreement, you may not (i) copy the
       Software, (ii) modify the Software or separate out any of its components for use
       with other software (except to the extent contemplated in the enclosed user
       documentation) (iii) use the Software to provide time sharing, service bureau or
       similar services, or (iv) decompile, disassemble, or otherwise reverse engineer
       the Software.

     * You may not allow anyone to do anything that this Agreement prohibits you from
       doing.

     (b) You understand that the Software is licensed to you and not sold. Surround
         retains title to all copies of the Software.

2.  LIMITED WARRANTIES AND DISCLAIMER OF IMPLIED WARRANTIES. (a) Surround
    warrants that, for ninety (90) days after you obtain the Software (the "Warranty
    Period"), (i) the Software will operate as stated in the enclosed user
    documentation, and (ii) the disk or other media on which the Software is
    provided will be free of defects in material or workmanship. This limited
    warranty does not cover anything caused by accident or abuse or by use of the
    Software other than for its reasonably intended purposes and as recommended in
    the accompanying user documentation. Also, Surround does not warrant that the
    operation of the Software will be uninterrupted or error free. This warranty
    gives you specific legal rights, and you may also have other rights which vary
    from state to state.

    (b) Except as stated in Section 2(a), Surround does not make any warranties. In
        particular, Surround disclaims all implied warranties, including the implied
        warranties of merchantability, fitness for a particular purpose, and non-
        infringement. The duration of any implied warranty that is not effectively
        disclaimed will be limited to the 90 day Warranty Period. Some states do not
        apply limitations on how long an implied warranty lasts, so the above limitation
        may not apply to you.

3.  EXCLUSIVE REMEDIES. (a) If, during the Warranty Period, you report any breach
    of warranty to Surround and Surround is reasonably able to verify that breach,
    Surround or its agent will, at its option, either (i) correct the Software or
    replace any defective media, (ii) help you work around or avoid the problem, or
    (iii) allow you to return the Software, all accompanying documentation, and all
    other accompanying written materials in the original packaging for a full
    refund. If you return the Software for a refund, you may not retain or use the
    Software, and you must immediately destroy all back-up copies and any other
    copies of the Software in your possession or control.

    (b) During the Warranty Period, you may report breaches of warranty over the
        phone by calling 908.490.1235 or by letter addressed to P.O. Box 47, Scotch
        Plains, NJ 07076, Attention: Customer Service. You must describe the breach in
        detail and include a phone number or address at which you can be reached during
        normal business hours. Surround will respond within a reasonable time to any
        reported breach. You must pay all costs of shipping any Software or other
        materials. Any corrected or replaced software that you obtain under this Agreement
        will be considered part of the Software licensed under this Agreement and will be
        covered by warranty only for any time remaining in the original Warranty Period.

    (c) The remedies stated in this Section 3 are your only rights or remedies, and
        will be Surround's only liability or obligation, for any breach by Surround of
        any warranty.

4.  PROPRIETARY RIGHTS. Subject to this Agreement, Surround and its licensors
    retain all copyrights, trade secret rights, patents, trademarks, and any other
    proprietary rights covering or relating to the Software. You acknowledge that
    the Software includes or incorporates proprietary and confidential information
    belonging to Surround and/or its licensors. All rights not expressly granted by
    Surround in this Agreement are reserved.

5.  EXCLUSION OF CONSEQUENTIAL DAMAGES; LIMITATION OF LIABILITY. Neither Surround
    nor its affiliates nor its licensors will be liable for any special, incidental,
    consequential or exemplary damages, including without limitation damages for
    loss of use, lost profits or loss of data or information of any kind, arising
    out of or in connection with the Software or its use or this Agreement, even if
    Surround Technologies or its affiliates or its licensor have been advised of the
    possibility of such damages. In no event will Surround's or its affiliates' or
    its licensors' liability for any claim relating to the Software or its use or
    this Agreement, whether in contract, tort or any other theory of liability,
    exceed the license fee paid by you. Some states do not allow the exclusion or
    limitation of incidental or consequential damages, so the above limitation or
    exclusion may not apply to you.

6.  CAUTIONS REGARDING DATA. The Software contains tools to be used in
    transmitting, searching, and retrieving data in various forms as described in
    the documentation. You assume the entire responsibility for determining the
    legality of any transmission or copying you may engage in and for protecting
    yourself, your business, family, and associates from any offensive or inaccurate
    data, information, or material you may choose to receive or allow to be
    transmitted to you. Without limiting the foregoing, if you access data from
    sources including, but not limited to, bulletin boards, data services, or the
    Internet, your access is provided only on an "as is" and "as available" basis.
    Surround does not grant any warranty with respect to, or assume any
    responsibility for any consequences whatsoever suffered by any person as a
    result of, your access or use of the Internet including, without limitation,
    access to or resulting in false, incomplete or unreliable data, sexually
    explicit or violent material, defamatory or derogatory content, computer
    viruses, or corrupted data.

7.  LIMITS ON YOUR RIGHT TO TRANSFER. You may not sublicense, rent, lease, lend,
    sell, grant a security interest in, or otherwise transfer the Software or any
    rights under this Agreement, except that you may transfer your copy of the
    Software if: (i) you transfer to the same person all copies of the Software and
    of any accompanying documentation in your possession or control, (ii) that
    person agrees in writing to assume all of your obligations under and otherwise
    to be bound by this Agreement, and (iii) you notify Surround at the address or
    phone number specified below of the transfer of the Software, including the
    name, address and phone number of the new owner of the Software and the serial
    number of the Software. Your rights under this Section 7 only apply to
    incidental transfers. No right is granted to transfer or in any way distribute
    multiple copies of the Software in connection with a trade or business (whether
    as a value added reseller, OEM, distributor, systems integrator, or otherwise).

8.  EXPORT. You acknowledge that the Software is subject to United States export
    control laws, including the export administration regulations. You will not
    export, re-export or divert the Software in contravention of those laws.

9.  TERMINATION. Surround may terminate this Agreement if you violate it. You
    must destroy all copies of the Software in your possession or control promptly
    upon termination. Upon Surround's request, you must certify in writing that you
    have complied with your obligations under this Section 9 and otherwise under
    this Agreement. Termination by Surround will not limit any of its other rights
    or remedies under this Agreement or at law or in equity. Any provision of this
    Agreement that by its sense and context is intended to survive termination of
    this Agreement will survive termination.

10.  SEVERABILITY. If any provision of this Agreement is illegal or
     unenforceable under applicable law, the remaining provisions of this Agreement
     will remain valid and fully enforceable. If any provision is in part enforceable
     and in part unenforceable, it will be enforced to the extent permitted under
     applicable law.

11.  U.S. GOVERNMENT RESTRICTED RIGHTS. If this product is licensed by a DoD
     agency, such agency's rights in this product are governed by the restrictions in
     the Technical Data -- Commercial Items clause at DFARS 252.227-7015 and DFARS
     227.7202, or any successor regulation. If this product is licensed by any other
     agency or instrumentality of the United States of America, use, duplication and
     disclosure are subject to restriction as set forth in subparagraphs (a) - (d) of
     the rights in Technical Data and Computer Software clause at FAR 52.227-19 or
     any successor regulation, or as set forth in the particular department or agency
     regulations or rules which provide Surround Technologies, LLC or its licensors
     protection equivalent to or greater than that clause.

12.  GOVERNING LAW. This Agreement is governed by New Jersey law.

13.  ENTIRE AGREEMENT. This Agreement, together with any special rights or
     promotions provided in writing with your copy of the Software, is the entire
     agreement between you and Surround relating to the Software. It supersedes any
     prior or contemporaneous oral or written communication relating to the Software.

Should you have any questions concerning this Agreement, or if you desire to contact
Surround Technologies, LLC for any reason, please write: P.O. Box 47, Scotch Plains,
NJ 07076, Attention: Customer Service. Alternatively, you may:
     Call Surround at (908) 490-1235,
     Fax Surround at (908) 490-1236, or
     Email Surround at surround_info@surroundtech.com

Copyright © 1998-2003 Surround Technologies, LLC.


Using this documentation.

This guide provides both instructional and reference material to help you understand the capabilities and functionality of the Systems File Exchange Tool. This guide contains a general overview of the system, samples of the menus used, and some screen displays. It also provides further details on entering and maintaining system information and perfroming file exchanges.

For Windows users:
This documentation set assumes that you are familiar with windows based programs, and can navigate through the interface using a mouse and keyboard.

For AS/400 users:
This documentation set assumes that you are familiar with the AS/400 environment, and can navigate through the interface using the keyboards function keys.

For Web users:
This documentation set assumes that you are familiar with the Internet and WWW environment, and can navigate through the interface using an Internet Browser.

Copyright © 1998-2002 Surround Technologies, LLC.


Introduction - Getting Started

Welcome to SFE

SFE Overview
What Is SFE?
Who is it for?
What does it do?
What does it look like?
What are its benefits?
How do you use it?

Understanding SFE
SFE Definitions

Installing SFE

Copyright © 1998-2002 Surround Technologies, LLC.


Welcome to the Systems File Exchange

Welcome to Surround Technologies’ AS/400 Communications Systems and Automation Software. The Systems File Exchange, SFE, is a file exchange utility for the AS/400 and Windows environments that allows you to easily and intelligently exchange files between multiple systems regardless of the host platform type or operating system. Exchanging files to and from other systems for use within an automated processing environment can often be complex and require special timing and processing. SFE helps to eliminate these complex requirements by acting as a middleware tool to manage and handle the file exchanges without the costly and complex EDI structures.

SFE allows you to interactively or programmatically load and unload files into the system for exchange with and from other systems. File exchange can be performed by either system in the exchange. It works with the Universal FTP Interface System, UFTP, to exchange the files and SFE information over FTP.

Exchanging files and data between multiple systems, platforms, and companies is a critical piece to a solid e-business infrastructure.

SFE provides this critical need effectively, dependably, and inexpensively.

Copyright © 1998-2002 Surround Technologies, LLC.


Systems File Exchange Overview

What Is The System File Exchange?
Who is it for?
What does it do?
What does it look like?
What are its benefits?
How do you use it?

Copyright © 1998-2002 Surround Technologies, LLC.


What is a SFE?

What is SFE?

The System File Exchange, or SFE, is a utility to manage the exchanging of files between multiple systems and platforms. SFE allows you to interactively or programmatically load and unload files into the system for exchange with and from other systems. File exchange can be performed by either system in the exchange. It works with the Universal FTP Interface System, UFTP, to exchange the files and SFE information via FTP.

SFE hides the complexities of managing the exchange of files between different systems, letting you concentrate on the business requirements for using the files.

SFE consists of 3 major pieces:

  • SFE Exchange Engine – The SFE Exchange Engine is the core of the actual file exchange process. It is a set of programs that dynamically assembles all the information from SFE to form UFTP sessions. Using UFTP sessions, SFE also gets information from the partner system and updates that information locally. The engine can be invoked interactively, from a scheduler system, or from within your other programs and systems.
  • SFE Maintenance and Administration – A full system to Maintain and Administer the SFE information and environment. Both a 5250 interface as well as a powerful Windows interface is available to work with, manage, and audit the SFE information and Exchanges.
  • SFE Tools – Tools to work with the SFE system such including programs to load and unload files into the system

Manage and handle complex file exchanges without the costly and complex EDI structures and software.

With sample scripts and wizards to create scripts quickly, protection of critical connection information to maintain a secure system, pre-built stable environment to reduce testing requirements, and multiple-platform support for full system integration, the overall time to deliver your essential file transfer solutions will be significantly decreased.

The End Result: significant reduction in costs and time from the the vary first file transfer requirement and beyond, allowing you to concentrate on using the data not transferring it. UFTP Pays for itself with the first script.

Easier, Faster, Cheaper, Better

Copyright © 1998-2002 Surround Technologies, LLC.


Who is it for?

Copyright © 1998-2002 Surround Technologies, LLC.


What does it do?

Copyright © 1998-2002 Surround Technologies, LLC.


What does it look like?

Copyright © 1998-2002 Surround Technologies, LLC.


What are its benefits?

Copyright © 1998-2002 Surround Technologies, LLC.


How do you use it?

Copyright © 1998-2002 Surround Technologies, LLC.


Understanding SFE

SFE Definitions
Exchange Partners
Exchange Partner Systems
Exchange Partner Groups
Exchange Files
Exchange File Types
Partner System Exchange Log
Exchange File Log
ID Numbers
SFE Connections

Copyright © 1998-2002 Surround Technologies, LLC.


SFE Definitions

Exchange Partners
Exchange Partner Systems
Exchange Partner Groups
Exchange Files
Exchange File Types
Partner System Exchange Log
Exchange File Log
ID Numbers
SFE Connections

Copyright © 1998-2002 Surround Technologies, LLC.


Exchange Partner (Definition)

An Exchange Partner is someone in which an agreement has been made to exchange files.

An Exchange Partner:

  • may have Partner Systems to exchange files between.

  • may have Partner Groups to exchange files with.

  • may have Exchange Files to exchange or have been exchanged.

  • may have Exchange Logs of previous exchange executions.

  • may use System Interfaces when executing an exchange.

  • may use Exchange File Forwarding to forward exchanged files to other Partner Systems.

Actions that can be performed on an Exchange Partner:

  • New, copy, view, edit, and delete Exchange Partners.

  • Maintain Partner Systems for Exchange Partner.

  • Maintain Partner Groups for Exchange Partner.

  • Maintain Exchange Files for Exchange Partner.

  • Maintain Exchange Logs for Exchange Partner.

  • Maintain System Interfaces for Exchange Partner.

  • Maintain Exchange File Forwarding for Exchange Partner.

  • Create a new Partner System for the Exchange Partner.

  • Create a new Partner Group for the Exchange Partner.

  • Run an Exchange - This will run the Exchange Execution utility with the Exchange Partner pre-filled. Other exchange parameters may also need to be specified.

  • Load a File for Exchange - This will invoke the Load Exchange File utility with the Exchange Partner pre-filled. Other exchange file parameters may also need to be specified.

  • Unload an Exchanged File - This will invoke the Unload Exchange File utility with the Exchange Partner pre-filled. Other exchange file parameters may also need to be specified.

Related Topics:
Partner System Definition
Partner Group Definition
5250 Users Interface:
Working With Partners
Working With Partner Systems
Working With Partner Groups
Windows Users Interface:
Browsing Exchange Partners
Defining An Exchange Partner
Defining A Partner System
Defining A Partner Group

Copyright © 1998-2003 Surround Technologies, LLC.


Defining An Exchange Partner

Partner System (Definition)

A Partner System is used to designate a specific system that an Exchange File is to be Transferred between.

For Example, you may use the following Partner Systems for a particular Exchange Partner:

System A | Used to designate files that are to be exchanged with System A.
System B | Used to designate files that are to be exchanged with System B.
NJ Office | Used to designate files that are to be exchanged with the System in New Jersey.
FL Office | Used to designate files that are to be exchanged with the System in Florida.

A Partner System:

  • belongs to an Exchange Partner. You can set up multiple systems for each Exchange Partner.
  • uses a UFTP Session to perform FTP functions and transfers.

  • may have Exchange Files to exchange or have been exchanged.

  • may have Exchange Logs of previous exchange executions.

  • may use System Interfaces when executing an exchange.

  • may use Exchange File Forwarding to forward exchanged files to other Partner Systems.

Actions that can be performed on a Partner System:

  • New, copy, view, edit, and delete Partner Systems.

  • Open Exchange Partner that Partner System belongs to.

  • Open UFTP Session that Partner System uses for Exchange.

  • Maintain Exchange Files for Partner System.

  • Maintain Exchange Logs for Partner System.

  • Maintain System Interfaces for Partner System.

  • Maintain Exchange File Forwarding for Partner System.

  • Execute an Exchange - This will invoke the Exchange Execution utility with the Exchange Partner and Partner System pre-filled. Other exchange parameters may also need to be specified.

  • Load a File for Exchange - This will invoke the Load Exchange File utility with the Exchange Partner and Partner System pre-filled. Other exchange file parameters may also need to be specified.

  • Unload an Exchanged File - This will invoke the Unload Exchange File utility with the Exchange Partner and Partner System pre-filled. Other exchange file parameters may also need to be specified.

Related Topics:
Exchange Partner Definition
5250 Users Interface:
Working With Partner Systems
Working With Exchange Partners
Working With Partner Systems for an Exchange Partner
Windows Users Interface:
Browsing Partner Systems
Defining A Partner System
Browsing Exchange Partners
Defining An Exchange Partner

Copyright © 1998-2003 Surround Technologies, LLC.


Defining An Exchange Partner

Partner Group (Definition)

A Partner Group is used to designate a specific group that an Exchange File is to be Transferred to. This allows you to set up one Exchange System and transfer files between multiple groups, departments, etc within that system.

For Example, you may use the following Partner Groups for a particular Exchange Partner:

Order Processing | Used to designate files that are for the Order Processing and Fulfillment Department.
Billing | Used to designate files that are for the Billing Department.

A Partner Group:

  • belongs to an Exchange Partner. You can set up multiple groups for each Exchange Partner.

  • may have Exchange Files to exchange or have been exchanged.

  • may be referenced by System Interfaces when executing an exchange.

  • may be referenced by Exchange File Forwarding to forward exchanged files.

Actions that can be performed on a Partner System:

  • New, copy, view, edit, and delete Partner Groups.

  • Open Exchange Partner that Partner Group belongs to.

  • Maintain Exchange Files for Partner Group.

  • Maintain System Interfaces that reference Partner Group.

  • Maintain Exchange File Forwarding that reference Partner Group.

  • Execute an Exchange - This will invoke the Exchange Execution utility with the Exchange Partner pre-filled. Other exchange parameters may also need to be specified.

  • Load a File for Exchange - This will invoke the Load Exchange File utility with the Exchange Partner and Partner Group pre-filled. Other exchange file parameters may also need to be specified.

  • Unload an Exchanged File - This will invoke the Unload Exchange File utility with the Exchange Partner and Partner Group pre-filled. Other exchange file parameters may also need to be specified.

Related Topics:
Exchange Partner Definition
5250 Users Interface:
Working With Partner Groups
Working With Exchange Partners
Working With Partner Groups for an Exchange Partner
Windows Users Interface:
Browsing Partner Groups
Defining A Partner Group
Browsing Exchange Partners
Defining An Exchange Partner

Copyright © 1998-2002 Surround Technologies, LLC.


Exchange File (Definition)

An Exchange File is a file that is being exchanged between two systems. The file information is stored in the Exchange File Index is either Loaded into the system to Exchange to a Partner System or is exchanged in from the other Partner System.

An Exchange File:

  • belongs to an Exchange Partner.
  • belongs to a Partner System.
  • may reference an Partner Group.
  • may reference an Exchange File Type.
  • may have Exchange File logs for when the file was exchanged.

Actions that can be performed on an Exchange File:

  • Load a File for Exchange - This will invoke the Load Exchange File utility to load a file into the system.

  • Unload an Exchanged File - This will invoke the Unload Exchange File utility with the Exchange File Information pre-filled. Other exchange file parameters may also need to be specified.

  • View, edit, and delete Exchange Files.

  • Open Exchange Partner that the Exchange File belongs to.

  • Open Partner System that the Exchange File belongs to.

  • Open Partner Group that the Exchange File belongs to.

  • Open File Type that the Exchange File belongs to.

  • Create a new Partner Group using the Exchanged in Partner Group (Only if the Partner Group Exchanged in does not already exist.)

  • Create a new File Type using the Exchanged in File Type (Only if the File Type Exchanged in does not already exist.)

  • Maintain Exchange File Logs for Exchange File.

  • Execute an Exchange - This will invoke the Exchange Execution utility with the Exchange Partner and System for the Exchange File pre-filled. Other exchange parameters may also need to be specified.

Related Topics:
Exchange Partner Definition
Partner System Definition
Partner Group Definition
Exchange File Type Definition
Exchange File Log Definition
5250 Users Interface:
Working With Exchange Files
Working With Exchange Files for an Exchange Partner
Loading a File For Exchange
Unloading A File
Executing an Exchange
Windows Users Interface:
Browsing Exchange Files
Reviewing Exchange File Properties
Loading a File For Exchange
Unloading A File
Executing an Exchange

Copyright © 1998-2003 Surround Technologies, LLC.


File Type (Definition)

Exchange File Type (Definition)

An Exchange File Type is used to identify a group of files used for a particular application.

For Example, you may use the following File Types:

Inventory | Used to identify all files used in processing a company's inventory.
Invoices | Used to identify all files used in processing invoices.
Orders | Used to identify all files used in processing orders.

An Exchange File Type:

  • may be referenced by Exchange Files that are being or have been exchanged.

  • may be referenced by System Interfaces when executing an exchange.

  • may be referenced by Exchange File Forwarding to forward exchanged files.

Actions that can be performed on an Exchange Partner:

  • New, copy, view, edit, and delete File Types.

  • Maintain Exchange Files that reference File Type.

  • Maintain System Interfaces that reference File Type.

  • Maintain Exchange File Forwarding that reference File Type.

  • Load a File for Exchange - This will invoke the Load Exchange File utility with the Exchange File Type pre-filled. Other exchange file parameters may also need to be specified.

  • Unload an Exchanged File - This will invoke the Unload Exchange File utility with the Exchange File Type pre-filled. Other exchange file parameters may also need to be specified.

Related Topics:
Exchange File Definition
5250 Users Interface:
Working With Exchange File Types
Windows Users Interface:
Browsing File Types
Defining a File Type

Copyright © 1998-2003 Surround Technologies, LLC.


Execution System Interface (Definition)

The System determines a System interface as follows:

Step 1) Check if System interface is specified in following order:

  1. For Specific Partner and System
  2. For Specific Partner (System not specified)
  3. Partner and System not specified

Step 2) If it finds a hit on one of those 3 scenarios, it will continue to look for a System interface in the following order.

  1. For "Once" per Exchange (Group and File Type not referenced)
    1. Use specified System Interface
  2. For "Each File" or for "Both Group and Type"
    1. For Specific Group and File Type
    2. For Specific Group
      System Interface Definition must have:
      Blank File Type
    3. Group and File Type not specified
      System Interface Definition must have:
      Zero Group ID
      Blank File Type
  3. For "Each Group" (File Type must be blank on System Interface)
    1. For Specific Group
      System Interface Definition must have:
      Blank File Type
    2. Group not specified
      System Interface Definition must have:
      Zero Group ID
      Blank File Type
  4. For "Each File Type"
    1. For Specific File Type
      System Interface Definition must have:
      Zero Group ID
    2. File Type not specified
      System Interface Definition must have:
      Zero Group ID
      Blank File Type

Related Topics:


Exchange File Forwarding (Definition)

Exchange File Forwarding is a powerful distribution feature of the system that allows you to automatically forward inbound exchange files to one or more other Partner Systems, Groups, and File Types. An Exchange File Forwarding system definition consists of a Forwarding From Control and one or more associated Forwarding To Controls.

Exchange File Forwarding:

  • may be for a specific Exchange Partner.
  • may be for a specific Partner System.
  • may be for a specific Partner Group.
  • may be for a specific Exchange File Type.
  • will forward to one or more other Exchange Partner Systems, Group, and File Type.

Actions that can be performed on Exchange File Forwarding:

  • New, copy, view, edit, and delete Exchange File Forwarding

  • Open Exchange Partner that is specified for the Exchange File Forwarding.

  • Open Partner System that is specified for the Exchange File Forwarding.

  • Open Partner Group that is specified for the Exchange File Forwarding.

  • Open File Type that is specified for the Exchange File Forwarding.

  • Maintain the Forwarding To Controls.

Related Topics:
Exchange Partner Definition
Partner System Definition
Partner Group Definition
Exchange File Type Definition
5250 Users Interface:
Working With Exchange File Forwarding
Windows Users Interface:
Browsing Exchange File Forwarding
Defining Exchange File Forwarding

Copyright © 1998-2003 Surround Technologies, LLC.


Partner System Exchange Log (Definition)

Exchange Log (Definition)

An Exchange Log is a log of exchanges that were executed between Partner Systems. A Log entry is created when ever an exchange is executed by either Partner System.

An exchange log will be designated as an Inbound Exchange if another Partner System initiated the exchange and is designated as an Outbound exchange if it initiated the exchange.

An Exchange Log:

  • belongs to an Exchange Partner.
  • belongs to a Partner System.

  • may have Exchange File Logs.

  • may have Exchange Log Points.

  • may have Exchange Log Messages.

Actions that can be performed on an Exchange Log:

  • View and delete Exchange Logs.

  • Open Exchange Partner that the Exchange Log belongs to.

  • Open Partner System that the Exchange Log belongs to.

  • Maintain Exchange File Logs for the Exchange Log.

  • Maintain Exchange Log Points for the Exchange Log.

  • Maintain Exchange Log Messages for the Exchange Log.

  • Execute an Exchange - This will invoke the Exchange Execution utility with the same Exchange Partner and Partner System as the Exchange Log pre-filled. Other exchange parameters may also need to be specified.

Related Topics:
5250 Users Interface:
Working With Exchange Logs
Reviewing An Exchange Log
Windows Users Interface:
Browsing Exchange Logs
Reviewing An Exchange Log

Copyright © 1998-2003 Surround Technologies, LLC.


Exchange File Log (Definition)

The Exchange File Log is a log of exchanges that were executed between Partner Systems for a particular exchange File. A Log entry is created when ever an exchange is executed for an exchange file by either Partner System.

Related Topics:
Reviewing Exchange File Properties
Browsing Exchange Logs
Reviewing An Exchange Log
Partner System Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Exchange Log Messages (Definition)

Related Topics:


Exchange Point (Definition)

Related Topics:


Defining An Exchange Partner

ID Number (Definition)

An ID Number is used internally by the system to keep track of the different objects within the system. An objects ID number is system generated and can not me modified. It is displayed and made available for selection wherever the object is referenced. Some users find it easier and faster to reference something by an ID number rather than a name. When creating a new object, the ID number will be zero and then automatically generated when the the object is saved.

SFE ID numbers are configured and maintained through the ID Number Maintenance. Information on how to do this, please refer to the UFTP User Guide for ID Number Configuration.

Some ID numbers can not be configured as they refer specifically to another Object. For Example, a Partner System refers specifically to a Partner and the ID number can not be configured.

The following Configurable ID numbers are used in the SFE system:

Exchange Partner
Exchange File
File Type

The following NON-configurable ID numbers are used in the SFE system:

Partner System
Partner Group
Exchange Log

Copyright © 1998-2003 Surround Technologies, LLC.


SFE Connection (Definition)

An SFE Connection is the Connection made between two systems using SFE.

An Inbound SFE Connection is a connection made to SFE from another outside system. Inbound Connections require the outside system to specify the SFE Partner System Name and the equivalent Password to gain access to SFE functions. This is an additional Security feature over and above your own existing Security system in place for FTP.

An Outbound SFE Connection is a connection made to an outside system. If connecting to another SFE system, SFE will use the Partner System Outbound System Name and Password to connect to that SFE system.

Related Topics:
Partner System Definition
Defining A Partner System
Exchange Partner Definition
Browsing Exchange Partners
Defining An Exchange Partner

Copyright © 1998-2003 Surround Technologies, LLC.


SFE 5250 Interface


SFE Menus

Copyright © 1998-2002 Surround Technologies, LLC.


SFE Work Withs

Views:

Options:

Function Keys

F1=Help | Get online context sensitive help.
F2= |
F3=Exit | Exit from the System
F4=Prompt | This Function Key is used to Prompt the user with a List of Values or Records to search through and select the required value. A promptable field usually has a + sign following it to indicate that the Prompt function is enabled for that field. If the Prompt Function Key is used while the Cursor is positioned on the View by: Field the System will Display a Pop-Up with a list of views to select from. If the Prompt Function Key is used while the Cursor is positioned on the Opt Field the System will display a Pop-Up with a list of Options to select from.
F5=Refresh | This Function Key is used to clear the List and refresh the information displayed.
F6=Add/Create | This Function Key is used to Create a new record.
F7=Left |
F8=Right |
F9=Command Line |
F10=Other | This Function Key is used to access the other functions available for Exchange Partners: (Only the functions that you have authority to will be available) 1) Print a user activity report. 2) Print a date range report for executed exchanges (Note: These Functions are not available in the current release.)
F11=Print List | This Function Key is used to Print a List of Exchange Partners. This Key will only be displayed if you have authority to Print a List of Exchange Partners. Refer to Printing a List of Exchange Partners (Note: This Function is not available in the current release.)
F12=Cancel |
F13= |
F14=Messages |
F15= |
F16= |
F17=Top | Go to the Top (first record) of the View.
F18=Bottom | Go to the Bottom (last record) of the View.
F19= |
F20=Hop |
F21=Filter/Posn To |
F22=Sel View |
F23=More Opt |
F24=More Keys |
Pg Up | Page Up
Pg Dn | Page Down
Enter Key | View Change: Option Processing: When an Option is entered next to an entry in the list and the Enter Key is pressed, the system will process that record with that option. Point and Shoot: When the Cursor is placed on an entry in the list and there are no Options selected the system will display a pop-up with all of allowed Options on it. You can then place your cursor on one of the Options and hit enter again. This will work the same as if you specified the Option on the Work With display.


SFE Details

Copyright © 1998-2002 Surround Technologies, LLC.


SFE Prompting


SFE On-line Help


SFE Windows Interface


SFE Logon


SFE Browsers

Copyright © 1998-2002 Surround Technologies, LLC.


SFE Detailers

Copyright © 1998-2002 Surround Technologies, LLC.


SFE Search And Selections

Copyright © 1998-2002 Surround Technologies, LLC.


SFE Other Interfaces

Sub-browsers

Sub-browsers are simply a way of browsing and maintaining objects that are referenced by, used by, or belong to another object.

Quick Add

Quick add is an interface to allow you to quickly add references to other objects onto the current object being defined. The quick add interface is usually shown above the toolbar of a reference list in an objects detailer and is hidden when you first open or create the object. To display the Quick Add interface, simple press the Quick Add button.

Copyright © 1998-2002 Surround Technologies, LLC.


SFE Web Interface


Installing SFE


SFE Tutorial

Setting Up An FTP Session

Copyright © 1998-2002 Surround Technologies, LLC.


Setting up a Partner System for File Exchange (Tutorial)

  1. Create a Partner
  2. Add a System to the Partner
    1. Select/Create a Transfer Session
      1. Select/Create a Site
      2. Select/Create a Script

Related Topics:
Defining A Partner System
Exchange Partner Definition
Browsing Exchange Partners
Defining An Exchange Partner

Copyright © 1998-2003 Surround Technologies, LLC.


SFE 5250 Users Interface


Accessing SFE (5250 Interface)

Using the STRSFE Command
Using the STRSFE Command to Load a file into SFE
Using the STRSFE Command to Unload files from SFE
Using the STRSFE Command to Run or Submit an SFE exchange

System File Exchange Menu

Copyright © 1998-2003 Surround Technologies, LLC.


Using the STRSFE Command

The STRSFE command can be used to easily access all of the SFE facilities. It can also be used to Load Files, Unload Files, or to execute an Exchange from the command line, within a scheduler, or inside of another program.

Command Parameters

Action Requested:
REQUEST() 		This is the action requested to be performed within SFE. The action requested can be up to 10 characters in length. The actions that may be requested include:
MENU: | Use the SFE Main Menu
LOAD: | Load a file into SFE to be exchanged
UNLOAD: | Unload files from SFE
RUN: | Execute (or Run) a Partner System Exchange
SUBMIT: | Submit a Partner System Exchange to Execute in Batch.

Additional Parameters

Partition to be used:
PARTITION() 		This is the Partition that is used for UFTP/SFE. The standard UFTP/SFE installation uses “FTL”, which is the default value for the command.

Example 1: To access the SFE Main Menu use the command:
STRSFE REQUEST(MENU)

Refer to Using the STRSFE Command to Load a file into SFE for use and additional parameters on the Load request.
Refer to Using the STRSFE Command to Unload files from SFE for use and additional parameters on the Unload request.
Refer to Using the STRSFE Command to Run or Submit an SFE exchange for use and additional parameters on the Run and Submit request.

Related Topics:


Using the STRSFE Command to Load a file into SFE

The STRSFE Request(Load) command can be used to Load files into SFE from a command line, within a scheduler, or from within other programs.

REQUEST(LOAD) Specific Parameters

Use Advanced Request: ADVANCED() | If Yes (the default value) then a more robust display will be presented that allows the user to search and select for information for the parameters of the request. Refer to Loading a File for Exchange. This is the recommended method for User initiated requests. If No, the SFE request will be performed directly from the STRSFE command. This value MUST be used if the request is being performed from a scheduler or another program
Exchange File Name: EXFILENM() | This is the name of the Exchange File you are loading. It can be anything you desire. It identifies the Exchange File you are loading. The length of this name is limited to 60 characters.
Exchange File Description: EXFILEDS() | This is a brief description of the Exchange File you are loading.
Exchange File Type: EXFILETY() | The File Type of the file.
Load File From LOADFROM() | The type of file to load. File: This is an OS/400 Physical File Save File: This is an OS/400 Save File
File To Be Loaded: LDFILE() | For File Load only. The File Name of the OS/400 file to be loaded.
Library: | The Library of the OS/400 file to be loaded.
Member: LDFILEMB() | The File Member of the OS/400 file to be loaded.
Save File To Be Loaded: LDSAVF() | For Save File Load only. The Save File Name of the OS/400 Save File to be loaded.
Library: | The Library of the OS/400 Save File to be loaded.
Exchange Partners PARTNER(() () () ...) | Up to 20 Partners can be specified to exchange the loaded file with.
Partner ID: | The Exchange Partner ID in which the file is being exchanged.
Partner System ID: | The Partner System ID in which the file is being exchanged.
Partner Group ID: | The Partner Group ID in which the file is being exchanged.
Exchange Comment: | Add any additional comments about the file being loaded and exchange.
Exchange Priority: | The relative exchange priority order of this Exchange File among others in the Exchange Process.
Transfer Mode: | Enter the FTP mode command to use when transferring the file. Typical values are: binary - Binary Mode Transfer ascii - ASCII Mode Transfer ebcdic - EBCDIC Mode Transfer This value need only be specified if you are transferring files of different data structures during the Exchange session. If the files are all of the same data structure, leave this value blank to use the mode specified in the Site "Startup Transfer Mode". Refer to the FTP Client Commands section of the UFTP user guide for more information on Transfer Mode Commands.
The following parameters are optional. If specified they will be used to define the file in the File Index of the Partner System.
Partner Exchange File Name: | The Partner System File Name to be specified when this file is exchanged to the other system. Leave blank to use the same Name as the one being loaded.
Partner Exchange File Description: | Enter the Exchange File Description to be specified when this file is exchanged to the other system. Leave blank to use the same Description as the one being loaded.
Partner Exchange File Type: | Enter the Exchange File Type to be specified when this file is exchanged to the other system. Leave blank to use the same File Type as the one being loaded.

Example 1: To load an invoice file to be exchanged with your customer, Partner 1 System 2 Group 3, and your shipping department, Partner 4 System 8, group 13, use a command similar to:
STRSFE REQUEST(LOAD)
ADVANCED(*NO)
EXFILENM('Invoices')
EXFILEDS('Invoices for 6/1/2002')
EXFILETY('Invoice')
LOADFROM(FILE)
LDFILE(STPRDDAT/IN020601)
LDFILEMB(*FIRST)
PARTNER((1 3 2 '''Please Review and Provide Payment (PO # SW12345)' 1 *N 'Bill (Surround Widgets)' 'Bills for 6/1/2002 from Surround Widgets' BILL) (4 8 13 'PO Recieved, Ship Widgets' 10))

Example 2: To load a save file of programs to be exchanged to a client, use a command similar to:
STRSFE REQUEST(LOAD)
ADVANCED(*NO)
EXFILENM('UFTP Update')
EXFILEDS('UFTP Update 6/1/2002')
EXFILETY('UFTP Upgrade')
LOADFROM('SAVE FILE')
LDSAVF(STGPL/UFTP4ISU02)
PARTNER((10 5 9 'Restore to all objects to QTEMP and execute command CALL QTEMP/STUFTPIN'))

When using the the STRSFE REQUEST(LOAD) command from within a CL program, it may be necessary to do something based on the outcome of the Exchange. This can be accomplished with the use of the MONMSG Command to monitor for messages:
Y169901 - SFE completed Exchange File Load successfully.
Y169989 - Error occurred while adding Partner to Exchange File Load.
Y169991 - SFE Exchange File Load FAILED.
The following CL commands demonstrate how to do this:

...
STRSFE REQUEST(UNLOAD) ...Y169988
MONMSG MSGID(Y169989) EXEC(SNDMSG MSG('File +
Load FAILED') TOUSR(QSYSOPR))
MONMSG MSGID(Y169991) EXEC(SNDMSG MSG('File +
Load FAILED') TOUSR(QSYSOPR))
MONMSG MSGID(Y169901) EXEC(SNDMSG MSG('File +
Load SUCCESSFUL') TOUSR(QSYSOPR))
...

Related Topics:

Copyright © 1998-2002 Surround Technologies, LLC.


Using the STRSFE Command to Unload files from SFE

The STRSFE REQUEST(UNLOAD) command can be used to Unload files out of SFE from a command line, within a scheduler, or from within other programs.

REQUEST(UNLOAD) Specific Parameters

Use Advanced Request:
ADVANCED() 		If Yes (the default value) then a more robust display will be presented that allows the user to search and select for information for the parameters of the request. Refer to Unloading a File. This is the recommended method for User initiated requests.

If No, the SFE request will be performed directly from the STRSFE command. This value must be used if the request is being performed from a scheduler or another program
Unload To:
UNLOADTO() 		The type of file to unload to.
File: This is an OS/400 Physical File.
Save File: This is an OS/400 Save File.
File Unload Option:
UNLOADOPT() 		For Unload To = FILE only.
REPLACE - If the File already exists, replace the data with the data being unloaded.
APPEND - If the File already exists, append the data being unloaded to the data already in the file.
File to be Unloaded to:
UNFILE() 		The OS/400 File Name to unload the file to.
Library: The OS/400 Library to unload the file to.
Member:
UNFILEMB() 		The OS/400 File Member to unload the file to.
Save File to be Unloaded to:
UNSAVF() 		The OS/400 Save File Name to unload the file to.
Library: The OS/400 Library to unload the file to.
Unload By:
UNLOADBY() 		Specify how to select the File to be unloaded. The options are:
R | Unload Received files by Exchange Partner and Type. For Unloading to FILE, all files that were received, a status of "Received", for the specified Exchange Partner, Partner System, Partner Gorup, and File Type. For unloading to a SAVE FILE, this will be the first available Exchange File of type SAVE FILE for the specified Partner, System, group, and Type.
I | Unload files with the specified Exchange File ID(s).
Partner ID:
UNPARTID() 		For Unload By = R only.
The Partner ID of the Partner received exchange files to unload.
Partner System ID:
UNSYSID() 		For Unload By = R only.
The Partner System ID of the Partner System received exchange files to unload.
Partner Group ID:
UNGRPID() 		For Unload By = R only.
The Partner Group ID of the Partner Group received exchange files to unload.
Exchange File Type:
UNFILETYPE() 		For Unload By = R only.
The Exchange File Type of the exchange files to unload.
Exchange File ID List:
EXFILEIDL(() () () ...) 		For Unload To = FILE and Unload By = I only.
Up to 20 ID Files can be specified. All files will be processed and appended in the order that they are specified.
Exchange file ID:
EXFILEID() 		For Unload To = 'SAVE FILE' and Unload By = I only.
The Exchange File ID to be Unloaded.

Example 1: Unload all received Bill files sent from Partner 4, System 6, and
   Group 5.
STRSFE REQUEST(UNLOAD)
ADVANCED(*NO)
UNLOADTO(FILE)
UNLOADOPT(REPLACE)
UNFILE(WMPRD/SW020601)
UNFILEMB(*FIRST)
UNLOADBY(R)
UNPARTID(4)
UNSYSID(6)
UNGRPID(5)
UNFILETYPE('Bill')

Example 2:
Unload a Save File from a specified Exchange File.
   STRSFE REQUESTUNLOAD
ADVANCED(*NO)
UNLOADTO('SAVE FILE')
UNSAVF(STGPL/UFTP4ISU02)
UNLOADBY(I)
EXFILEID(251)

When using the the STRSFE REQUEST(UNLOAD) command from within a CL program, it may be necessary to do something based on the outcome of the Exchange. This can be accomplished with the use of the MONMSG Command to monitor for messages:
Y169902 - SFE completed Exchange File Unload successfully.
Y169988 - Error occurred while adding Exchange File to Exchange File Unload.
Y169992 - SFE Exchange File Unload FAILED.
The following CL commands demonstrate how to do this:

...
STRSFE REQUEST(UNLOAD) ...Y169988
MONMSG MSGID(Y169988) EXEC(SNDMSG MSG('File +
Unload FAILED') TOUSR(QSYSOPR))
MONMSG MSGID(Y169992) EXEC(SNDMSG MSG('File +
Unload FAILED') TOUSR(QSYSOPR))
MONMSG MSGID(Y169902) EXEC(SNDMSG MSG('File +
Unload SUCCESSFUL') TOUSR(QSYSOPR))
...

Related Topics:

Copyright © 1998-2002 Surround Technologies, LLC.


Using the STRSFE Command to Run or Submit an SFE exchange

The STRSFE REQUEST(RUN) or STRSFE REQUEST(SUBMIT) command can be used to execute an exchange from the command line, within a scheduler, or inside of another program.

REQUEST(RUN) and REQUEST(SUBMIT) Specific Parameters

Use Advanced Request: ADVANCED() | If Yes (the default value) then a more robust display will be presented that allows the user to search and select for information for the parameters of the request. Refer to Loading a File for Exchange. This is the recommended method for User initiated requests. If No, the SFE request will be performed directly from the STRSFE command. This value MUST be used if the request is being performed from a scheduler or another program
Partner ID: PARTNERID() | The Exchange Partner ID in which the file is being exchanged.
Partner System ID: SYSTEMID() | The Partner System ID in which the file is being exchanged.

To execute an Exchange with Partner 1 and System 1 use the command:
STRSFE REQUEST(RUN) ADVANCED(*NO) PARTNERID(1) SYSTEMID(1)

When using the the STRSFE REQUEST(RUN) command from within a CL program, it may be necessary to do something based on the outcome of the Exchange. This can be accomplished with the use of the MONMSG Command to monitor for messages:
Y169900 - SFE completed exchange successfully.
Y169990 - SFE Exchange FAILED.
The following CL commands demonstrate how to do this:

...
STRSFE REQUEST(RUN) ADVANCED(*NO) PARTNER(1) +
SYSTEMID(1)
MONMSG MSGID(Y169990) EXEC(SNDMSG MSG('SFE +
Exchange FAILED') TOUSR(QSYSOPR))
MONMSG MSGID(Y169900) EXEC(SNDMSG MSG('SFE +
Exchange SUCCESSFUL') TOUSR(QSYSOPR))
...

Related Topics:

Copyright © 1998-2002 Surround Technologies, LLC.


Using the SFE Menu

The SFE Menu can be accessed using the STRSFE or STRSFE REQUEST(MENU) command. It can also be accessed from the "Universal FTP - System File Exchange" option on the UFTP Main Menu.

This menu is the main access to the different SFE features:

  1. Load an Exchange File -
  2. Unload an Exchange File -
  3. Execute a System Exchange -
  4. Work With Partners -
  5. Work With Partner Systems -
  6. Work With Partner Groups -
  7. Work With Exchange File Index -
  8. Work With Exchange Logs -
  9. Work With File Types -
  10. Work With System Interfaces -
  11. Work With Forwarding -
  12. Universal FTP System -
  13. Universal FTP System - FTP Reference -
  14. System Maintenance -
  15. Security -

Related Topics:


SFE Maintenance (5250 Interface)

Working With Partners

Copyright © 1998-2002 Surround Technologies, LLC.


Working With Partners

The Partner Work With provides the ability to browse, search, and work with the Exchange Partners that are defined in the system.

View by:

Enter the View Number and Press Enter to sort the Exchange Partners by that View or Press F4=Prompt to select from a list of Views available for Exchange Partners. For more information on these features refer to the Function Keys section of this guide and review the Function Keys usage of F4=Prompt Function Key, F21=Posn To Function Key and F22=Sel View Function Key.

The available views for Exchange Partners are:

01 | View By Exchange Partner ID.
02 | View By Name
03 | View By Description
04 | View Active By Exchange Partner ID
05 | View Active By Name
06 | View Active By Description
07 | View Inactive By Exchange Partner ID
08 | View Inactive By Name
09 | View Inactive By Description
90 | View By Create User and Date
91 | View By Create Date
92 | View By Last Change User and Date
93 | View By Last Change Date
94 | Recycle Bin: View By User and Date
95 | Recycle Bin: View By Date

Options:

The following options are available for Exchange Partners. They will only be displayed if you have authority to that option.

2=Edit | This Option will allow the User to change an existing Exchange Partner. Refer to Editing an Exchange Partner.
3=Copy | This Option will allow the User to copy an existing Exchange Partner. Refer to Copying a Exchange Partner.
4=Delete | This Option will allow the User to delete an existing Exchange Partner. Refer to Deleting an Exchange Partner.
6=Print | This Option will allow the User to print existing Exchange Partners. Refer to Printing Exchange Partners. Note: This Option not available in the current release.
8=View | This Option will allow the User to view an existing Exchange Partner. Refer to Viewing an Exchange Partner.
11=Run | This Option will open the "Run an SFE Exchange" utility with the Exchange Partner pre-filled.
12=Submit | This Option will open the "Submit an SFE Exchange" utility with the Exchange Partner pre-filled.
13=Load | This Option will open the "Load an Exchange File" utility with the Exchange Partner pre-filled.
14=Unload | This Option will open the "Unload an Exchange File" utility with the Exchange Partner pre-filled.
20=Notes | This Option will allow the User to Work With the Notes for the Exchange Partner.
21=Groups | This Option will allow the User to Work With the Partner Groups for the Exchange Partner.
22=Systems | This Option will allow the User to Work With the Partner Systems for the Exchange Partner.
23=Exchange Files | This Option will allow the User to Work With the Exchange Files for the Exchange Partner.
24=Exchange Logs | This Option will allow the User to Work With the Exchange Logs for the Exchange Partner.
25=System Interfaces | This Option will allow the User to Work With the System Interfaces for the Exchange Partner.
26=Forwarding | This Option will allow the User to Work With the Exchange File Forwarding for the Exchange Partner.

Function Keys

The following functions keys are available for Exchange Partners. They will only be displayed if you have authority to that Function.

F1=Help | Get online context sensitive help.
F3=Exit | Exit from the System
F4=Prompt | This Function Key is used to Prompt the user with a List of Values or Records to search through and select the required value. A promptable field usually has a + sign following it to indicate that the Prompt function is enabled for that field. If the Prompt Function Key is used while the Cursor is positioned on the View by: Field the System will Display a Pop-Up with a list of views to select from. To see what this Pop-Up will look like refer to the F22=Sel View Function Key. If the Prompt Function Key is used while the Cursor is positioned on the Opt Field the System will display a Pop-Up with a list of Options to select from. To see what this Pop-Up will look like refer to the Enter Key function. (Note: This Function Key for the Opt Field is not available in the current release.)
F5=Refresh | This Function Key is used to clear the List and refresh the information displayed.
F6=Add/Create | This Function Key is used to Create an Exchange Partner. Refer to Creating an Exchange Partner.
F10=Other | This Function Key is used to access the other functions available for Exchange Partners: (Only the functions that you have authority to will be available) 1) Print a user activity report. 2) Print a date range report for executed exchanges (Note: These Functions are not available in the current release.)
F11=Print List | This Function Key is used to Print a List of Exchange Partners. This Key will only be displayed if you have authority to Print a List of Exchange Partners. Refer to Printing a List of Exchange Partners. (Note: This Function is not available in the current release.)
F12=Cancel |
F21=Posn To |
F22=Sel View |
F23=More Opt |
Enter Key | View Change: Option Processing: When an Option is entered next to an entry in the list and the Enter Key is pressed, the system will process that record with that option. Point and Shoot: When the Cursor is placed on an entry in the list and there are no Options selected the system will display a pop-up with all of allowed Options on it. You can then place your cursor on one of the Options and hit enter again. This will work the same as if you specified the Option on the Work With display.

Related Topics:
Exchange Partner Definition
5250 Interface - Work Withs

Copyright © 1998-2003 Surround Technologies, LLC.


Creating an Exchange Partner

Creating a Session

Related Topics:
Exchange Partner Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Copying an Exchange Partner

Copying a Session

Related Topics:
Exchange Partner Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Editing an Exchange Partner

Editing a Session

Related Topics:
Exchange Partner Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Viewing an Exchange Partner

Viewing a Session

Related Topics:
Exchange Partner Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Deleting an Exchange Partner

Deleting a Session

Related Topics:
Exchange Partner Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Selecting Exchange Partners

Selecting Sessions

Related Topics:
Session Exchange Partner

Copyright © 1998-2003 Surround Technologies, LLC.


Printing Exchange Partners

Related Topics:
Exchange Partner Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Printing a List of Exchange Partners

Related Topics:
Exchange Partner Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Working With Notes (for an Exchange Partner)

Related Topics:


Working With Partner Groups (for an Exchange Partner)

The Partner Group Work With provides the ability to browse, search, and work with the Partner Groups that are defined in the system.

View by:

Enter the View Number and Press Enter to sort the Sessions by that View or Press F4=Prompt to select from a list of Views available for Sessions. For more information on these Features go to the Work Withs section of this guide and review the Function Keys usage of F4=Prompt Function Key, F21=Posn To Function Key and F22=Sel View Function Key.

The available views for Partner Groups are:

01 - View By Session ID
02 - View By Name
03 - View By Description
04 - View By FTP Site ID
05 - View By Script ID
90 - View By Create User and Date
91 - View By Create Date
92 - View By Last Change User and Date
93 - View By Last Change Date
94 - Recycle Bin: View By User and Date
95 - Recycle Bin: View By Date

Options

2=Edit

3=Copy

4=Delete

6=Print

8=View

11=Run

12=Submit

20=Notes

21=Session Logs

22=Substitution Variables

Related Topics:
Partner Group Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Working With Partner Systems (for an Exchange Partner)

The Partner System Work With for an Exchange Partner provides the ability to browse, search, and work with the Partner Systems that are defined in the system for a particular Exchange Partner.

View by:

Enter the View Number and Press Enter to sort the Partner Systems by that View or Press F4=Prompt to select from a list of Views available for Partner Systems. For more information on these features refer to the Function Keys section of this guide and review the Function Keys usage of F4=Prompt Function Key, F21=Posn To Function Key and F22=Sel View Function Key.

The available views for Partners Systems are:

01 | View By Partner System ID.
07 | View By Partner and System Name
08 | View Active By Partner System ID
13 | View Active By Partner and System Name
14 | View Inactive By Partner System ID
19 | View Inactive By Partner and System Name
90 | View By Create User and Date
91 | View By Create Date
92 | View By Last Change User and Date
93 | View By Last Change Date
94 | Recycle Bin: View By User and Date
95 | Recycle Bin: View By Date

Options:

Refer to Working With Partner Systems.

Function Keys

Refer to Working With Partner Systems.

Related Topics:
Partner System Definition
Partner Definition
5250 Users Interface:
Working With Partners
Working With Partner Systems
Working With Partners

Copyright © 1998-2003 Surround Technologies, LLC.


Working With Exchange Files (for an Exchange Partner)

Related Topics:


Working With Exchange Logs (for an Exchange Partner)

Related Topics:


Working With System Interfaces (for an Exchange Partner)

Related Topics:


Working With Exchange File Forwarding (for an Exchange Partner)

Related Topics:


Working With Partner Groups

The Partner Group Work With provides the ability to browse, search, and work with the Partner Groups that are defined in the system.

View by:

Enter the View Number and Press Enter to sort the Sessions by that View or Press F4=Prompt to select from a list of Views available for Sessions. For more information on these Features go to the Work Withs section of this guide and review the Function Keys usage of F4=Prompt Function Key, F21=Posn To Function Key and F22=Sel View Function Key.

The available views for Partner Groups are:

01 - View By Session ID
02 - View By Name
03 - View By Description
04 - View By FTP Site ID
05 - View By Script ID
90 - View By Create User and Date
91 - View By Create Date
92 - View By Last Change User and Date
93 - View By Last Change Date
94 - Recycle Bin: View By User and Date
95 - Recycle Bin: View By Date

Options

2=Edit

3=Copy

4=Delete

6=Print

8=View

11=Run

12=Submit

20=Notes

21=Session Logs

22=Substitution Variables

Related Topics:
Partner Group Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Working With Partner Systems

The Partner System Work With provides the ability to browse, search, and work with the Partner Systems that are defined in the system.

View by:

Enter the View Number and Press Enter to sort the Partner Systems by that View or Press F4=Prompt to select from a list of Views available for Partner Systems. For more information on these features refer to the Function Keys section of this guide and review the Function Keys usage of F4=Prompt Function Key, F21=Posn To Function Key and F22=Sel View Function Key.

The available views for Partners Systems are:

01 | View By Partner System ID.
02 | View By Name
03 | View By Description
04 | View By Transfer Session ID
05 | View By Outbound ID and System Name
06 | View By Inbound ID and System Name
07 | View By Partner and System Name
08 | View Active By Partner System ID
09 | View Active By Name
10 | View Active By Description
11 | View Active By Outbound ID and System Name
12 | View Active By Inbound ID and System Name
13 | View Active By Partner and System Name
14 | View Inactive By Partner System ID
15 | View Inactive By Name
16 | View Inactive By Description
17 | View Inactive By Outbound ID and System Name
18 | View Inactive By Inbound ID and System Name
19 | View Inactive By Partner and System Name
90 | View By Create User and Date
91 | View By Create Date
92 | View By Last Change User and Date
93 | View By Last Change Date
94 | Recycle Bin: View By User and Date
95 | Recycle Bin: View By Date

Options:

The following options are available for Partner Systems. They will only be displayed if you have authority to that option.

2=Edit | This Option will allow the User to change an existing Partner System. Refer to Editing a Partner System.
3=Copy | This Option will allow the User to copy an existing Partner System. Refer to Copying a Partner System.
4=Delete | This Option will allow the User to delete an existing Partner System. Refer to Deleting a Partner System.
6=Print | This Option will allow the User to print existing Partner Systems. Refer to Printing Partner Systems. Note: This Option not available in the current release.
8=View | This Option will allow the User to view an existing Partner System. Refer to Viewing a Partner System.
11=Run | This Option will open the "Run an SFE Exchange" utility with the Exchange Partner and Partner System pre-filled.
12=Submit | This Option will open the "Submit an SFE Exchange" utility with the Exchange Partner and Partner System pre-filled.
13=Load | This Option will open the "Load an Exchange File" utility with the Exchange Partner and Partner System pre-filled.
14=Unload | This Option will open the "Unload an Exchange File" utility with the Exchange Partner and Partner System pre-filled.
20=Notes | This Option will allow the User to Work With the Notes for the Partner System.
21=Exchange Files | This Option will allow the User to Work With the Exchange Files for the Partner System.
22=Exchange Logs | This Option will allow the User to Work With the Exchange Logs for the Partner System.
23=System Interfaces | This Option will allow the User to Work With the System Interfaces for the Partner System.
24=Forwarding | This Option will allow the User to Work With the Exchange File Forwarding for the Partner System.

Function Keys

The following functions keys are available for Partner Systems. They will only be displayed if you have authority to that Function.

F1=Help | Get online context sensitive help.
F3=Exit | Exit from the System
F4=Prompt | This Function Key is used to Prompt the user with a List of Values or Records to search through and select the required value. A promptable field usually has a + sign following it to indicate that the Prompt function is enabled for that field. If the Prompt Function Key is used while the Cursor is positioned on the View by: Field the System will Display a Pop-Up with a list of views to select from. To see what this Pop-Up will look like refer to the F22=Sel View Function Key. If the Prompt Function Key is used while the Cursor is positioned on the Opt Field the System will display a Pop-Up with a list of Options to select from. To see what this Pop-Up will look like refer to the Enter Key function. (Note: This Function Key for the Opt Field is not available in the current release.)
F5=Refresh | This Function Key is used to clear the List and refresh the information displayed.
F6=Add/Create | This Function Key is used to Create a Partner System. Refer to Creating a Partner System.
F10=Other | This Function Key is used to access the other functions available for Partner Systems: (Only the functions that you have authority to will be available) 1) Print a user activity report. 2) Print a date range report for executed exchanges (Note: These Functions are not available in the current release.)
F11=Print List | This Function Key is used to Print a List of Partner Systems. This Key will only be displayed if you have authority to Print a List of Partner Systems. Refer to Printing a List of Partner Systems. (Note: This Function is not available in the current release.)
F12=Cancel |
F21=Posn To |
F22=Sel View |
F23=More Opt |
Enter Key | View Change: Option Processing: When an Option is entered next to an entry in the list and the Enter Key is pressed, the system will process that record with that option. Point and Shoot: When the Cursor is placed on an entry in the list and there are no Options selected the system will display a pop-up with all of allowed Options on it. You can then place your cursor on one of the Options and hit enter again. This will work the same as if you specified the Option on the Work With display.

Related Topics:
Partner System Definition
Working With Partner System for a Partner System


Working With File Types

The File Type Work With provides the ability to browse, search, and work with the File Types that are defined in the system.

Related Topics:
File Type Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Working With System Interfaces

The File Type Work With provides the ability to browse, search, and work with the System Interfaces that are defined in the system.

Related Topics:
System Interface Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Working With Exchange File Forwarding

The Exchange File Forwarding Work With provides the ability to browse, search, and work with the System Interfaces that are defined in the system.

Related Topics:
Exchange File Forwarding Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Exchanging Files (5250 Interface)


Working With Exchange Files

The Exchange File Work With provides the ability to browse, search, and work with the Exchange Files that are defined in the system.

Related Topics:
Exchange File Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Loading A File For Exchange

An Exchange File can be loaded into the system Interactively through the Load Exchange File Utility.

Load Exchange File Utility

[Put Load Exchange File Screen Print here]

Name | This is the name of the Exchange File you are defining. It can be anything you desire. It identifies the Exchange File you are loading. The length of this name is limited to 60 characters.
Description | This is a brief description of the Exchange File you are loading.
File Type | The File Type of the file.
Load From File | The required information here will be different depending on if the SFE system is on an iSeries or Windows Machine.
Library | The Library of the OS/400 file to be loaded.
File | The File Name of the OS/400 file to be loaded.
Member | The File Member of the OS/400 file to be loaded.
File Path | The File Path of the PC file to be loaded. This value is limited to 200 characters.
File Name | The File Name of the PC file to be loaded. This value is limited to 20 characters.

Exchange Partner - Enter the partner information and use the Quick Add button to specify the Partners that this file will be transferred to. You must enter at least one.

Exchange Partner | The Exchange Partner in which the file is being exchanged.
Partner System | The Partner System in which the file is being exchanged.
Partner Group | The Partner Group in which the file is being exchanged.
Exchange Comment | Add any additional comments about the file being loaded and exchange.
Exchange Priority | The relative exchange priority order of this Exchange File among others in the Exchange Process
Transfer Mode | Enter the FTP mode command to use when transferring the file. Typical values are: binary - Binary Mode Transfer ascii - ASCII Mode Transfer ebcdic - EBCDIC Mode Transfer This value need only be specified if you are transferring files of different data structures during the Exchange session. If the files are all of the same data structure, leave this value blank to use the mode specified in the Site "Startup Transfer Mode". Refer to the FTP Client Commands section of the UFTP user guide for more information on Transfer Mode Commands
Specify Partner System Exchange File | Check this box if the Partner system uses a different Exchange File Name, Description, or File Type than what is being loaded.

If the "Specify Partner System Exchange File" box is checked, a dialog will be displayed to specify the Partner System Exchange File information. These Parameters are Optional. If specified they will be used to define the file in the File Index of the Partner System.

Partner System File Name | Enter the Partner System File Name to be specified when this file is exchanged to the other system. Leave blank to use the same Name as the one being loaded.
Partner System File Description | Enter the Exchange File Description to be specified when this file is exchanged to the other system.. Leave blank to use the same Description as the one being loaded.
Partner System File Type | Enter the Exchange File Type to be specified when this file is exchanged to the other system.. Leave blank to use the same File Type as the one being loaded.

Load Exchange File Command (OS/400)

On the AS400 or iSeries, loading Exchange Files can also be performed from a Command Line, Scheduler, or from within your programs using the Load Request on the Start SFE command.

STRSFE REQUEST(LOADFILE) ...

Refer to Using the STRSFE Command for more information on using this command.

Copyright © 1998-2002 Surround Technologies, LLC.


Unloading A File

An Exchange File can be unloaded into the system Interactively through the Unload Exchange File Utility.

Unload Exchange File Utility

[Put Unload Exchange File Screen Print here]

Unload By Specify how to select the File to be unloaded. The options are:
First of Name: | This is the first file with the Exchange File Name specified available that has not been unloaded yet (The file with the latest date and a status of "Exchanged".
Last of Name: | This is the last file with the Exchange File Name specified available that has not been unloaded yet (The file with the latest date and a status of "Exchanged".
First of Type: | This is the first file with the File Type specified available that has not been unloaded yet (The file with the latest date and a status of "Exchanged".
Last of Type: | This is the last file with the File Type specified available that has not been unloaded yet (The file with the latest date and a status of "Exchanged".
File ID: | Unload the file with a specific Exchange File ID.
Name
File Type
Exchange File ID
Load To File | The required information here will be different depending on if the SFE system is on an iSeries or Windows Machine.
Library | The Library of the OS/400 to unload the file to.
File | The File Name of the OS/400 to unload the file to.
Member | The File Member of the OS/400 to unload the file to.
File Path | The File Path of the PC to unload the file to. This value is limited to 200 characters.
File Name | The File Name of the PC to unload the file to. This value is limited to 20 characters.

Unload Exchange File Command (OS/400)

On the AS400 or iSeries, unloading Exchange Files can also be performed from a Command Line, Scheduler, or from within your programs using the UNLOADFILE Request on the Start SFE command.

STRSFE REQUEST(UNLOADFILE) ...

Refer to Using the STRSFE Command for more information on using this command.


Executing an Exchange

Related Topics:
\


Working With Exchange Logs

The Exchange Log Work With provides the ability to browse, search, and work with the System Interfaces that are defined in the system.

Related Topics:
Exchange Log Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Reviewing An Exchange Log

An Exchange Log can be.


Reviewing An Exchange File Log

An Exchange Log can be.


SFE Windows User Interface

Accessing SFE
Using the SFE Browser
Using the UFTP Browser
Using the STRSFE.EXE Program

Maintenance
Browsing Exchange Partners
Defining An Exchange Partner
Defining A Partner System
Defining A Partner Group
Browsing File Types
Defining A File Type

Exchanging Files

Copyright © 1998-2003 Surround Technologies, LLC.


Accessing SFE (Windows Interface)

Using the SFE Browser
Using the UFTP Browser
Using the STRSFE.EXE Program

Copyright © 1998-2002 Surround Technologies, LLC.


Using the SFE Browser

The SFE installation will put an Icon on the Windows Desktop and an item in the Windows Start Menu under "Start-Programs-Universal FTP & SFE".

Windows Desktop Icon:
Windows Start Menu:

Both the Windows Desktop icon and the Start Menu Item can be used to start up the SFE Browser.
The user will be presented with a Logon screen similar to the one below.

enter the necessary connection information and press connect to access the Browser.

The Browser ...

Related Topics:

Copyright © 1998-2002 Surround Technologies, LLC.


Using the UFTP Explorer

The SFE facilities can also be accessed from within the UFTP Explorer as well.

Refer to the "Using the UFTP Browser" section of the UFTP Guide for more information on using the UFTP Browser.

The Browser ...

Related Topics:

Copyright © 1998-2002 Surround Technologies, LLC.


Using the STRSFE.EXE Program

The STRSFE.EXE Program can be used to easily access all of the SFE facilities. It can also be used to Load Files, Unload Files, or to execute an Exchange from the command line, within a scheduler, or inside of another Windows program.

Command Switches

Action Requested: |
MENU: |
LOAD: |
UNLOAD: |
RUN: |
SUBMIT: |
Partition to be used: | This is the Partition that is used for UFTP/SFE. The standard UFTP/SFE installation uses “FTL”, which is the default value for the command.

LOAD Request Specific Switches

Additional Partner For Exchange File

UNLOAD Request Specific Switches

RUN Request Specific Switches

SUBMIT Request Specific Switches

Related Topics:

Copyright © 1998-2002 Surround Technologies, LLC.


SFE Maintenance (Windows Interface)

Browsing Exchange Partners
Defining An Exchange Partner
Defining A Partner System
Defining A Partner Group
Browsing File Types
Defining A File Type

Copyright © 1998-2002 Surround Technologies, LLC.


Browsing Exchange Partners

The Exchange Partner Browser provides the ability to browse, search, and work with the Exchange Partners that are defined in the system.

New and existing Exchange Partner maintenance can be performed through this browser. From here it is possible to search for existing entries and to work with or create new ones. Different views and values are available to search and position to the Exchange Partner entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, creating, editing, deleting, and printing Exchange Partners.

Search:

The available views to search by for Exchange Partners are:

View By Exchange Partner ID
View By Name
View By Description
View Active By Exchange Partner ID
View Active By Name
View Active By Description
View Inactive By Exchange Partner ID
View Inactive By Name
View Inactive By Description
View By Create User and Date
View By Create Date
View By Last Change User and Date
View By Last Change Date

Recycle Bin:

Preview Pane:

Related Topics:
Exchange Partner Definition
Defining An Exchange Partner

Copyright © 1998-2003 Surround Technologies, LLC.


Defining An Exchange Partner

A Exchange Partner can be created or changed through the Exchange Partner Detail window. The Exchange Partner Detail can be accessed through the Exchange Partner Browser or from anywhere in the system that an Exchange Partner is used.

Detail Tab

Exchange Partner ID | This is the ID Number used for this Exchange Partner.
Name | This is the name of the Exchange Partner you are defining. It can be anything you desire. It identifies the Exchange Partner you are creating and is the name you will choose when specifying the Exchange Partner for a file you are loading into the file exchange. The length of this name is limited to 60 characters.
Description | This is a brief description of the Exchange Partner you are defining.
Active | Uncheck this box to make the Partner inactive and stop all exchanges performed with it.
Notes | Enter in any Notes you would like about this Partner System.

Partner Groups Tab

This tab displays a Partner Group Browser that provides the ability to browse, search, and work with the Partner Groups that are defined for this Exchange Partner.

New and existing Partner Group maintenance can be performed through this browser. From here it is possible to search for existing entries and to work with or create new ones. Different views and values are available to search and position to the Partner Group entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, creating, editing, deleting, and printing Partner Systems.

Partner Systems Tab

This tab displays a Partner System Browser that provides the ability to browse, search, and work with the Partner Systems that are defined for this Exchange Partner.

New and existing Partner System maintenance can be performed through this browser. From here it is possible to search for existing entries and to work with or create new ones. Different views and values are available to search and position to the Partner System entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, creating, editing, deleting, and printing Partner Systems.

Exchange Files Tab

This tab displays an Exchange File Browser that provides the ability to browse, search, and work with the Exchange Files that are in the Exchange System for this Exchange Partner.

Exchange Files can be loaded, unloaded, and maintained through this browser. From here it is possible to search for existing entries and to work with or load new ones. Different views and values are available to search and position to the Exchange File entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, loading, unloading, deleting, and printing Exchange Files.

Related Topics:
Exchange Partner Definition
Partner System Definition
Defining A Partner System
Partner Group Definition
Defining A Partner Group
Exchange File Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Browsing Partner Systems

The Partner System Browser provides the ability to browse, search, and work with the Partner Systems that are defined in the system.

New and existing Partner System maintenance can be performed through this browser. From here it is possible to search for existing entries and to work with or create new ones. Different views and values are available to search and position to the Partner System entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, creating, editing, deleting, and printing Partner Systems.

Related Topics:
Partner System Definition
Defining A Partner System

Copyright © 1998-2003 Surround Technologies, LLC.


Defining An Exchange Partner

Defining A Partner System

A Partner System can be created or changed through the Partner System Detail window. The Partner System Detail can be accessed from within the Partner Systems tab on the Exchange Partner Detail or from anywhere in the system that a Partner System is used.

Detail Tab

Exchange Partner | The Exchange Partner that this System Belongs to.
System ID | This is the ID Number used for this System.
Name | This is the name of the Partner System you are defining. It can be anything you desire. It identifies the System you are creating and is the name you will choose when specifying the System for a file you are loading into the file exchange. The length of this name is limited to 60 characters. The Partner System Name must be specified correctly by an Inbound SFE Connection.
Description | This is a brief description of the Partner System you are defining.
Exchange Type |
System File Format |
UFTP Session | This is the UFTP Session that will be used to actually perform the FTP File transfers.
Inbound Exchange ID |
Inbound Password | This is the password that is used by an outside system to establish an Inbound SFE Connection with this system.
Outbound Exchange ID | This is the name of the SFE System that this system is to establish an Outbound SFE Connection with.
Outbound Password | This is the password to be used to establish an Outbound SFE Connection.
System Has System Exchange | Check this box to designate that the system you are connecting to also has SFE. This tells the system that it can utilize the SFE functionality on both sides of the connection.
Maximum Transfers per Exchange Session | This is the maximum number of files that you would like to limit while performing the system exchange. Sometimes, based on the stability of your connection it may be better to reduce the number of transfers allowed. The default value is 9,999 which is the value to use for an unlimited number of transfers.
Notes | Enter in any Notes you would like about this Partner System.

Exchange File Index Tab

This tab displays an Exchange File Browser that provides the ability to browse, search, and work with the Exchange Files that are in the Exchange System for this Partner System.

Exchange Files can be loaded, unloaded, and maintained through this browser. From here it is possible to search for existing entries and to work with or load new ones. Different views and values are available to search and position to the Exchange File entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, loading, unloading, deleting, and printing Exchange Files.

Related Topics:
Exchange Partner Definition
Partner System Definition
Exchange File Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Browsing Partner Groups

The Partner System Browser provides the ability to browse, search, and work with the Partner Groups that are defined in the system.

New and existing Partner System maintenance can be performed through this browser. From here it is possible to search for existing entries and to work with or create new ones. Different views and values are available to search and position to the Partner System entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, creating, editing, deleting, and printing Partner Groups.

Related Topics:
Partner Group Definition
Defining A Partner Group

Copyright © 1998-2003 Surround Technologies, LLC.


Defining An Exchange Partner

Defining A Partner Group

A Partner Group can be created or changed through the Partner Group Detail window. The Partner Group Detail can be accessed from within the Partner Groups tab on the Exchange Partner Detail or from anywhere in the system that a Partner Group is used.

Detail Tab

Exchange Partner | The Exchange Partner that this Group Belongs to.
Group ID | This is the ID Number used for this Group.
Name | This is the name of the Partner Group you are defining. It can be anything you desire. It identifies the Group you are creating and is the name you will choose when specifying the Group for a file you are loading into the file exchange. The length of this name is limited to 60 characters.
Description | This is a brief description of the Partner Group you are defining.
Notes | Enter in any Notes you would like about this Partner Group.

Exchange Files Tab

This tab displays an Exchange File Browser that provides the ability to browse, search, and work with the Exchange Files that are in the Exchange System for this Partner Group.

Exchange Files can be loaded, unloaded, and maintained through this browser. From here it is possible to search for existing entries and to work with or load new ones. Different views and values are available to search and position to the Exchange File entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, loading, unloading, deleting, and printing Exchange Files.

Related Topics:
Exchange Partner Definition
Partner Group Definition
Exchange File Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Browsing File Types

The File Type Browser provides the ability to browse, search, and work with the File Types that are defined in the system.

New and existing File Type maintenance can be performed through this browser. From here it is possible to search for existing entries and to work with or create new ones. Different views and values are available to search and position to the File Type entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, creating, editing, deleting, and printing File Types.

Related Topics:
File Type Definition
Defining A File Type

Copyright © 1998-2002 Surround Technologies, LLC.


Defining A File Type

A File Type can be created or changed through the File Type Detail window. The File Type Detail can be accessed through the File Type Browser or from anywhere in the system that a File Type is used.

Detail Tab

File Type ID | This is the ID Number used for this File Type.
Name | This is the name of the File Type you are defining. It can be anything you desire. It identifies the File Type you are creating and is the name you will choose when specifying the File Type of files you are loading into the file exchange. The length of this name is limited to 60 characters.
Description | This is a brief description of the File Type you are defining.
Notes | Enter in any Notes you would like about this File Type.

Exchange Files Tab

This tab displays an Exchange File Browser that provides the ability to browse, search, and work with the Exchange Files that are in the Exchange System with this File Type.

Exchange Files can be loaded, unloaded, and maintained through this browser. From here it is possible to search for existing entries and to work with or load new ones. Different views and values are available to search and position to the Exchange File entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, loading, unloading, editing, deleting, and printing Exchange Files.

Related Topics:
File Type Definition
Exchange File Definition

Copyright © 1998-2002 Surround Technologies, LLC.


Browsing Execution System Interfaces

The Execution System Interface Browser provides the ability to browse, search, and work with the Execution System Interfaces that are defined in the system.

New and existing Execution System Interface maintenance can be performed through this browser. From here it is possible to search for existing entries and to work with or create new ones. Different views and values are available to search and position to the Interface entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, creating, editing, deleting, and printing Execution System Interfaces.

Related Topics:
Execution System Interface Definition
Defining An Execution System Interface

Copyright © 1998-2003 Surround Technologies, LLC.


Defining An Execution System Interface

An Execution System Interface can be created or changed through the Execution System Interface Detail window. This detail window can be accessed through the Execution System Interface Browser or from anywhere in the system that an Execution System Interface is used.

Detail Tab

Execution System Interface ID | This is the ID Number used for this System.
Name | This is the name of the Execution System Interface you are defining. It can be anything you desire. It identifies the Interface you are creating and is the name you will choose when specifying the Interface in other parts of the system. The length of this name is limited to 60 characters.
Description | This is a brief description of the Execution System Interface you are defining.
Notes | Enter in any Notes you would like about this Execution System Interface.

EESI Commands

Once the Exchange Execution System Interface (EESI) is saved, the EESI Commands Browser panel displays that provides the ability to browse, search, and work with the Commands to execute for the interface.

Commands can be loaded, unloaded, and maintained through this browser. From here it is possible to search for existing entries and to work with or create new ones. Different views and values are available to search and position to the Command entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, loading, unloading, deleting, and printing Commands.

Related Topics:
Execution System Interface Definition
EESI Command Definition

Copyright © 1998-2003 Surround Technologies, LLC.


Browsing Exchange Files

Browsing Exchange File Forwarding

Related Topics:


Defining Exchange File Forwarding

Detail Tab

Related Topics:


Exchanging Files (Windows Interface)


Browsing Exchange Files

This Exchange File Browser provides the ability to browse, search, and work with the Exchange Files that are in the Exchange System.

Exchange Files can be loaded, unloaded, and maintained through this browser. From here it is possible to search for existing entries and to work with or load new ones. Different views and values are available to search and position to the Exchange File entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, loading, unloading, deleting, and printing Exchange Files.

Related Topics:
Reviewing Exchange File Properties
Loading A File For Exchange
Unloading A File

Copyright © 1998-2002 Surround Technologies, LLC.


Reviewing Exchange File Properties

An Exchange File can be reviewed and maintained through the Exchange File Detail window. The Exchange File Detail can be accessed through the Exchange File Browser or from anywhere in the system that an Exchange File is used.

Detail Tab

The Exchange File Information cannot be edited from this window. The screen print above is for a File that was Loaded and is ready to be sent to the Exchange Partner. Below is a Screen Print of for a file that was Recieved from the Partner. The information being reviewed here is created when the file is loaded or exchanged in from the Partner System.

Exchange File ID | This is the ID Number used for this Exchange File.
Name | This is the name of the Exchange File you are reviewing. This value is entered when a File is loaded into the Exchange System.
Description | This is a brief description of the Exchange File.
File Type | The File Type specified for the file.
Exchange Partner | The Exchange Partner in which the file is being exchanged.
Partner System | The Partner System in which the file is being exchanged.
Partner Group | The Partner Group in which the file is being exchanged.
Exchange Type | This is a system maintained value that tells you whether this file is exchanged "In" or "Out" of your system. It is set to "In" when the system exchanges a file into SFE. It is set to "Out" when a file is loaded into SFE for Exchange out to the system.
Exchange Comment | Additional Comments about the Exchange File.
Partner System Information This group of information represents the Exchange File properties on the other Partners System.
This information can be very useful to determine and resolve Exchange File errors.
Partner System File ID | The Exchange File ID on the Partner System.
Partner System File Name | The Exchange File Name on the Partner System.
Partner System File Description | The Exchange File Description on the Partner System.
Partner System File Type | The Exchange File Type on the Partner System.
Exchange Priority | The relative exchange priority order of this Exchange File among others in the Exchange Process
Exchange Status The status of the Files exchange.
For "Out" type:
Pending | The file was loaded and is pending transfer to the System during the next exchange.
InProgress | An exchange has started and this file has been queued for transfer out.
Hold | The file transfer is held and will not be transferred during the next exchange.
Canceled | The file was loaded, but the transfer was canceled before it was sent.
Sent | The file has been exchanged successfully.
Failed | The file exchange failed, manual intervention is required.
For "In" type:
Pending | Not Applicable for "In" Types.
InProgress | An exchange has started and this file has been queued for transfer in.
Hold | Not Applicable for "In" Types.
Canceled | Not Applicable for "In" Types.
Received | The file has been exchanged successfully.
Forwarded | The file was forwarded to another partner system
Unloaded | The file has been unloaded.
Failed | The file exchange failed, manual intervention is required.
Transfer Mode This is the FTP mode command used when transferring the file. Typical values are:
binary - Binary Mode Transfer
ascii - ASCII Mode Transfer
ebcdic - EBCDIC Mode Transfer
Refer to the FTP Client Commands section of the UFTP user guide for more information on Transfer Mode Commands
Record Width | The maximum record width of the file.
Record Count | The number of records in the file.
File Size | The physical size of the file.

Exchange File Log Tab

This tab displays the Exchange File Log Browser that provides the ability to browse, search, and work with the Exchange File Logs that are in the Exchange System for this Exchange File.

Exchange File Logs can be reviewed and maintained through this browser. Different views and values are available to search and position to the Exchange File log entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, deleting, and printing Exchange File Logs.

Related Topics:
Exchange File Definition
Exchange File Log Definition
Reviewing An Exchange File Log

Copyright © 1998-2002 Surround Technologies, LLC.


Loading A File For Exchange

An Exchange File can be loaded into the system Interactively through the Load Exchange File Utility.

Load Exchange File Utility

Name | This is the name of the Exchange File you are defining. It can be anything you desire. It identifies the Exchange File you are loading. The length of this name is limited to 60 characters.
Description | This is a brief description of the Exchange File you are loading.
File Type | The File Type of the file.
Load From File | The required information here will be different depending on if the SFE system is on an iSeries or Windows Machine.
Library | The Library of the OS/400 file to be loaded.
File | The File Name of the OS/400 file to be loaded.
Member | The File Member of the OS/400 file to be loaded.
File Path | The File Path of the PC file to be loaded. This value is limited to 200 characters.
File Name | The File Name of the PC file to be loaded. This value is limited to 20 characters.

Exchange Partner - Enter the partner information and use the Quick Add button to specify the Partners that this file will be transferred to. You must enter at least one.

Exchange Partner | The Exchange Partner in which the file is being exchanged.
Partner System | The Partner System in which the file is being exchanged.
Partner Group | The Partner Group in which the file is being exchanged.
Exchange Comment | Add any additional comments about the file being loaded and exchange.
Exchange Priority | The relative exchange priority order of this Exchange File among others in the Exchange Process
Transfer Mode | Enter the FTP mode command to use when transferring the file. Typical values are: binary - Binary Mode Transfer ascii - ASCII Mode Transfer ebcdic - EBCDIC Mode Transfer This value need only be specified if you are transferring files of different data structures during the Exchange session. If the files are all of the same data structure, leave this value blank to use the mode specified in the Site "Startup Transfer Mode". Refer to the FTP Client Commands section of the UFTP user guide for more information on Transfer Mode Commands
Specify Partner System Exchange File | Check this box if the Partner system uses a different Exchange File Name, Description, or File Type than what is being loaded.

If the "Specify Partner System Exchange File" box is checked, a dialog will be displayed to specify the Partner System Exchange File information. These Parameters are Optional. If specified they will be used to define the file in the File Index of the Partner System.

Partner System File Name | Enter the Partner System File Name to be specified when this file is exchanged to the other system. Leave blank to use the same Name as the one being loaded.
Partner System File Description | Enter the Exchange File Description to be specified when this file is exchanged to the other system.. Leave blank to use the same Description as the one being loaded.
Partner System File Type | Enter the Exchange File Type to be specified when this file is exchanged to the other system.. Leave blank to use the same File Type as the one being loaded.

Load Exchange File Command (Windows)

On Windows, loading Exchange Files can also be performed from a Run Command, Task Scheduler, or from within your programs using the UNLOADFILE Request on the Start SFE Program.

STRSFE.EXE /r (load) ...

Refer to Using the STRSFE.EXE Program for more information on using this command.

Copyright © 1998-2002 Surround Technologies, LLC.


Unloading A File

An Exchange File can be unloaded into the system Interactively through the Unload Exchange File Utility.

Unload Exchange File Utility

[Put Unload Exchange File Screen Print here]

Unload By | Specify how to select the File to be unloaded: First of Name - This is the first file available that has not been unloaded yet (The file with the earliest date and a status of "Exchanged" Last of Name - This is the last file available that has not been unloaded yet (The file with the latest date and a status of "Exchanged" First of Type - Last of Type - ID - Unload the file with a specific Exchange File ID.
Name |
File Type |
Exchange File ID |
Load To File | The required information here will be different depending on if the SFE system is on an iSeries or Windows Machine.
Library | The Library of the OS/400 to unload the file to.
File | The File Name of the OS/400 to unload the file to.
Member | The File Member of the OS/400 to unload the file to.
File Path | The File Path of the PC to unload the file to. This value is limited to 200 characters.
File Name | The File Name of the PC to unload the file to. This value is limited to 20 characters.

Unload Exchange File Command (Windows)

On Windows, Unloading Exchange Files can also be performed from a Run Command, Task Scheduler, or from within your programs using the UNLOADFILE Request on the Start SFE Program.

STRSFE.EXE /r (unloadfile) ...

Refer to Using the STRSFE.EXE Program for more information on using this command.

Copyright © 1998-2002 Surround Technologies, LLC.


Executing the Systme Exchange

Executing the System Exchange

A System Exchange occurs between two Partner Systems and can be executed by either of the Partners.

Copyright © 1998-2002 Surround Technologies, LLC.


Browsing Exchange Files

Browsing Exchange Logs

The Exchange Log Browser provides the ability to browse, search, and work with the Exchange Logs that are in the Exchange System.

Exchange Logs can be reviewed and maintained through this browser. Different views and values are available to search and position to the Exchange Log entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, deleting, and printing Exchange Logs.

Related Topics:
Reviewing Exchange File Properties
Loading A File For Exchange
Unloading A File

Copyright © 1998-2002 Surround Technologies, LLC.


Reviewing An Exchange Log

An Exchange Log can be.

Detail Tab

[Put Exchange Log Detail Screen Print here]

Partner |
System |
Exchange Log ID |
Exchange Type | Inbound Outbound
Exchange Session |
Exchange Execution |
Completion Status |

Exchange File Log Tab

This tab displays the Exchange File Log Browser that provides the ability to browse, search, and work with the Exchange File Logs that are in the Exchange System for this Exchange Log.

Exchange File Logs can be reviewed and maintained through this browser. Different views and values are available to search and position to the Exchange File log entries of interest. From here it is possible to perform certain tasks based on user authority, including but not limited to viewing, deleting, and printing Exchange File Logs.


Reviewing An Exchange File Log

An Exchange File Log can be .

Detail Tab

[Put Exchange File Log Detail Screen Print here]

Partner
System
Exchange Log
Exchange File
File Exchange Completion Status

Copyright © 1998-2003 Surround Technologies, LLC.


SFE Web User Interface


SFE Maintenance (Web Interface)

Working With Partners

Copyright © 1998-2003 Surround Technologies, LLC.


Exchanging Files (Web Interface)


Customer Support

The System File Exchange is developed and serviced by Surround Technologies, LLC.
We can be reached by phone Monday though Friday between 8:00 AM and 6:00 PM, Eastern Standard Time. You can also reach Surround Technologies at our the Web site or by e-mail via the Internet.

If your question is not answered in the help file or in this developer guide, please

check our web site at | http://www.surroundtech.com
e-mail us at: | surround_info@surroundtech.com
contact our Customer Service: | (908) 490-1235
or Fax us at: | (908) 490-1236

Note: When reporting a problem, please use this template, ST Support Request, to create an Observation and Support Request, OSR, and make sure to include all relevant information including:

  • What version of the software are you using?
    (Click on Help and then About to find out what version you are using),
  • What Operating Environment are you using?
    (AS/400, Windows 95, Windows 98, Windows NT, Windows 2000, Windows XP, UNIX, etc...)
  • What feature are you using?
  • What happens when you use the feature?
  • If possible, a screen print of the observation is very helpful.

If you need to contact Surround Technologies for a reason other than technical support, our mailing address is:

Surround Technologies, LLC
PO Box 47
Scotch Plains, NJ 07076

Copyright © 1998-2003 Surround Technologies, LLC.


Copyright Information

Copyright Information.


Copyright Information

System File Exchange
Version 1.2
July 1, 2003

Copyright © 1998-2003 SURROUND TECHNOLOGIES, LLC.
All rights reserved worldwide

NOTICE:
This user guide and the Software described by this user guide are protected by copyright. You may not copy, modify, translate, or reproduce this user guide or any part of this user guide in any form without prior written permission from Surround Technologies, LLC.
The software associated with this product is governed by a license agreement and may be used only under strict adherence to the terms of that license agreement.

IBM, AS/400 and OS/400 are registered trademarks of IBM Corporation.
LANSA is a registered trademark of LANSA, Inc.
Microsoft Windows, Microsoft Word, and Microsoft Excel are registered trademarks of Microsoft Corporation

Frameworks for Windows and all the Drill Down Development Tools are Developed by:
Surround Technologies, LLC
PO Box 47
Scotch Plains, NJ 07076
http://www.surroundtech.com
(908) 490-1235

COPYRIGHT 2003 SURROUND TECHNOLOGIES, LLC
All rights reserved.


Execution System Interface (Definition)

An Execution System Interface is ...

Copyright © 1998-2002 Surround Technologies, LLC.